win

12.04

ubuntu_setup_script

  Run updates
  sudo apt-get purge command-not-found*
  Thin out startup items
      Re-enable full list
          mkdir -p ~/.config/autostart
          cd ~/.config/autostart
          cp /etc/xdg/autostart/*.desktop .
          sed -i "s/NoDisplay=true/NoDisplay=false/g" *.desktop
      then upper right => Startup applications
          disable zeitigist (logs user activity)
  Thin out services
      http://www.hecticgeek.com/2012/06/few-things-to-speed-up-ubuntu/
      sudo apt-get install bum
      gksudo bum
  Disable bug reporting
      /etc/default/apport
      enabled=0
      sudo service apport stop
  Remove file backup tool
      sudo apt-get autoremove deja-dup
  Optional: remove zeitigeist entirely
      sudo apt-get autoremove zeitgeist-core
      not sure if good idea
  Optional: clear package cache
      sudo apt-get clean
      (installation downloads a lot of used once packages)
  Download gedit 2.28.4
      http://ftp.gnome.org/pub/GNOME/sources/gedit/2.28/gedit-2.28.4.tar.bz2
      It has nicer search/replace behavior
  Desktop
      Install gnome-session-fallback
      Logout of current user
      Select session gnome classic (no effects and login)
      Uninstall unity if desirable
  Install gnome-do
  Uninstall Ubuntu One
      Quit the Ubuntu One client
      rm -rf ~/.local/share/ubuntuone ~/.cache/ubuntuone ~/.config/ubuntuone
      sudo apt-get purge ubuntuone-client* python-ubuntuone-storage*
  Uninstall Ubuntu Software Center
      sudo apt-get purge software-center
  No mystery meat scrollbar
      12.04: gsettings set org.gnome.desktop.interface ubuntu-overlay-scrollbars false
          you need to log out and back in to take effect
      14.04: gsettings set com.canonical.desktop.interface scrollbar-mode normal
  Disable unused services
  Optional: install 32 bit compatibility
  Install dev tools
      sudo apt-get install gcc gcc-g++ make
      sudo apt-get install kernel-devel
      sudo apt-get install python-pip ipython
      Oracle Java
  Misc
      sudo apt-get purge rhythmbox*
      sudo apt-get purge empathy
      # With MIDI
      sudo apt-get install vlc vlc-plugin-fluidsynth
svn 1.7
# Don't need to uninstall 1.6 first
sudo echo ''>>/etc/apt/sources.list
sudo echo 'deb http://ppa.launchpad.net/svn/ppa/ubuntu precise main'>>/etc/apt/sources.list
sudo echo 'deb-src http://ppa.launchpad.net/svn/ppa/ubuntu precise main'>>/etc/apt/sources.list
sudo apt-get update
sudo apt-get install subversion

More proper way might be something like
sudo add-apt-repository ppa:user/ppa-name
 Non-production VM
      sudo apt-get purge thunderbird*
      Change password complexity requirement
          /etc/pam.d/common-password
          Original
              password	[success=1 default=ignore]	pam_unix.so obscure sha512
          To
              password    [success=1 default=ignore]  pam_unix.so minlen=1 sha512
  Chrome
      I created a Search Engine named "No", gave it the keyword "null" and set the url to "http://%s".  Then set it to be the default search engine.  This effectively disables search.
  Install TrueCrypt
  VMWare
      fix the desktop size at startup thing
  WINE
  Hugin
  Gimp
  Inkscape
  Show seconds on clock
      gsettings set com.canonical.indicator.datetime show-seconds true

Firefox disable remembering per site:

about:config
browser.download.lastDir.savePerSite
boolean w/ value false

.gitconfig

[user]
	name = John McMaster
	email = JohnDMcMaster@gmail.com
[color]
	ui = false
[push]
	default = simple
[pack]
    packSizeLimit = 128m
    threads = 4
    windowMemory = 16m

eclipse startup

# for verilog stuff
PATH=/opt/jdk1.7.0_60/bin:$PATH /usr/bin/eclipse

14.04

Overall evaluation

  • Fixed: W520 volume control
  • A number of small things that make it less usable over 12.04
    • Most of these I was able to work around, see below
  • My other W520 is running 12.04 without issue
  • W520 may have longer battery life under 14.04 (need to look into this more)
  • 14.04 is supposed to TRIM (some) SSDs
  • Serial port tab completion bug
  • Don't like extra /media nautilus level (12.04 /media/MYDRIVE ⇒ 14.04 /media/$USER/MYDRIVE)
  • Media automounting removed…definitely noticeable but neutral on this
  • W520: don't use proprietary nvidia driver
  • Broke existing printer (with easy fix)

screen tab completion workaround

# Tab complete anything
echo "complete -f -X '!*' screen">>~/.bashrc

Shorter nautilus mount path:

sudo ln -s /media/$USER /m
# gnome-open
sudo apt-get install libgnome2-bin
# usable desktop environment
sudo apt-get install -y gnome-session-fallback

# 32 bit libs
sudo apt-get install gcc-multilib

12 to 14 upgrade

Consider uninstalling anything special you did

sudo apt-get update
sudo apt-get upgrade
# sudo apt-get install update-manager-core
# apt-cache policy update-manager-core
sudo do-release upgrade

Problems

Outright bugs or anything that lessens productivity over 12.04

Had installed on personal desktop for a bit as a trial and didn't have any major issues. This machine gets light use and was to weed out any major issues. Similarly

screen tab completion: on 12.04 I could tab complete USB serial portrs. On 14.04 I can't even though I can open them. This looks to be some sort of tab completion permisson prediction failure (group vs other error?)

gedit:

  • GUI itself didn't seem to change much (although I still like the 10.04 gedit the best)
  • Opening a document via command line doesn't give gedit focus anymore. I relied on this feature heavily
    • Workaround: create a gedit executable with (assuming ~/bin is in your path)
cat>~/bin/gedit <<EOF
/usr/bin/gedit "\$@"
wmctrl -a gedit
EOF
chmod +x ~/bin/gedit
sudo apt-get install -y wmctrl
  • Crashed on me a few times already, but possibly due to me mistakenly uninstalling it. Watch it and see if it has problems

gnome-disks (formerly palimpsest)

  • Renamed. Not a huge deal, but a minor annoyance since I now have to track which distro I'm on
  • Buttons are now less accessible (“tablet friendly”)

git

  • Added coloring. branch name highlighted dark green on black terminal (the default). Low contrast / hard to read: disabled coloring
    • git config –global color.ui false

screen / tab completion on serial port

  • Although I can open the serial port (member of dialout, system restarted) won't let me tab complete
  • If chmod 777 the serial port it lets me tab complete
  • Seems to not be matching group vs other correctly

gthumb

sudo apt-get install -y itstool gsettings-desktop-schemas gsettings-desktop-schemas-dev libtiff4-dev
wget https://download.gnome.org/sources/gthumb/3.2/gthumb-3.2.8.tar.xz
tar -xf gthumb-3.2.8.tar.xz
cd gthumb-3.2.8
./configure
make
sudo make install

nautilus

  • Clicking on already opened ssh connections on left pane did not open windows (none were open). Shortly thereafter, I tried to close the ssh sessions (hit the eject buttons) and got an Ubuntu crash message. Re-opening the SSH connections did allow the windows to pop up

Sleep, screen lock

  • Screen lock slow: minimum of 1 second, often times many more
  • At least once screen did not come back on after screen lock. Re-docking the W520 caused it to come back on
  • TODO: is this related to the large screen I have? See if its quicker without external display

screenshot: changed from automatic save to prompting. Need an option to auto save

  • workaround: put the following script in your path
  • /usr/bin/gnome-screenshot -f “$HOME/Pictures/Screenshot from $(date '+%F %T').png” $@

W520 general notes

  • 12.04 W530 while back: too unstable. In particular would not always wake up from sleep
    • How different are these models?
    • Note: windows 7 would fail maybe 5% of the time but it was failing maybe 20% of the time. Poor hardware?
  • After using it for short period of time I have not had any resume failures
  • nVidia vs intel graphics switching support? Am I going to get reduced performance and/or battery life?
    • Using nvidia only graphics
    • Proprietary nvidia drivers randomly freezes the screen (but not the computer)
      • clear by ctrl-alt-f1, ctrl-alt-f7
      • Present in both 352.63 and 340.96
      • nouveau shows no issues. If perf is okay stick to it
      • glxinfo |grep -i vendor
  • Improvement: volume buttons do not work in 12.04 but do work in 14.04
  • RAM

Evince 3.10.3:

  • Find functionality is not as quick as it used to be:
    • ^F: used to always pop up find. Now it toggles it on and off. This makes it difficult to consistently get focus when I ^F to find something
    • Also find pops up a list and sometimes cycles through the list instead of going to next item
    • Roll back to Ubuntu 12.04 version (3.4.0) or find a different pdf viewer
sudo apt-get install -y libgail-3-dev libgnome-keyring-dev libnautilus-extension-dev libpoppler-glib-dev intltool gnome-doc-utils
wget http://ftp.gnome.org/pub/GNOME/sources/evince/3.4/evince-3.4.0.tar.xz
tar -xf evince-3.4.0.tar.xz
cd evince-3.4.0
./configure
make
sudo make install

Printer

  • Symptom: Idle - Directory “/usr/lib/cups/filter/Dell_2150_Color_Printer” has insecure permissions (040775/uid=0/gid=0).
    • drwxrwxr-x 2 root root 4.0K Feb 22 2015 /usr/lib/cups/filter/Dell_2150_Color_Printer
  • Cause: new CUPS permission model. Old printer setup not compatible
  • Solution: change permissions from 775 to 755
    • sudo chmod 755 /usr/lib/cups/filter/Dell_2150_Color_Printer

Pidgin

  • Sometimes I need to support self-signed / invalid certs
  • 14.04 Pidgin/purple (2.10.9) cannot accept self-signed certs through the GUI
  • I tried some command line solutions but they didn't work for our particular instance
    • Was unable to fetch SSL cert via command line, web browser, etc
  • Workaround: install 2.10.11
    • sudo apt-get install -y libgstreamer-plugins-base0.10-dev network-manager-dev libperl-dev libgnutls-dev tcl-dev tk-dev

remount read only

Tested 12.04

sudo mount -o remount,rw /dev/sda1 /

RAID5

Tested 12.04

If you use the palimpsest GUI it may create poorly aligned partitions. Instead, suggest you create the array by command line (hopefully this is fixed in later Ubuntus…)

format w/ good alignment

for dev in /dev/sd{h,i,j}; do
    sgdisk -Z $dev
    sgdisk -n 1:2048:5860533134 $dev
    sgdisk -t 1:fd00 $dev
done

if md already

mdadm --zero-superblock /dev/sde
mdadm --zero-superblock /dev/sd{h,i,j}
deleted partions in palimpsest

create the array

mdadm --create /dev/md1 --level=5 --raid-devices=3 /dev/sd{h,i,j}1 --name=media5_3

add spare to media5_3 (broken sata connector…oops)

mdadm --manage /dev/md127 --add /dev/sdd1

ssh

ssh banner

For ubuntu 12.04 at least

sudo vim /etc/issue.net

  • message here

sudo vim /etc/ssh/sshd_config

  • Banner /etc/issue.net

sudo vim /etc/pam.d/sshd

  • #session optional pam_motd.so # [1]

sudo /etc/init.d/ssh restart

GSSAPI hang

Symptom: ssh slow

Cause: ssh client is attempting to do GSSAPI authentication. If you don't use this, consider disabling it to speed up handshaking

echo "GSSAPIAuthentication no">>~/.ssh/config
chmod 600 ~/.ssh/config

DNS hang

Symptom: ssh -v shows hang after “debug1: SSH2_MSG_SERVICE_ACCEPT received”

Cause: sshd is attempting to reverse DNS the client. Often clients don't have reverse DNS making this process slow

Solution: disable this lookup. vim /etc/ssh/sshd_config

UseDNS no
echo "UseDNS no" |sudo tee -a /etc/ssh/sshd_config
sudo /etc/init.d/ssh restart

sshfs hang

ie from using sshfs, sftp in nautilus (gvfs), etc

I've found that 14.04 hangs my UI a lot more than 12.04 from broken SSH connections although I haven't really pinpointed exactly what causes this to happen. Experimenting with more aggressively closing broken connections

30 second timeout:

/etc/ssh/ssh_config

ServerAliveInterval 10
ServerAliveCountMax 3

new admin user

adduser newuser

usermod -a -G adm,dialout,cdrom,sudo,dip,plugdev,lpadmin,sambashare newuser

serial port permission

usermod -a -G dialout

root script

#!/usr/bin/env bash
if [ $UID -ne 0 ] ; then
    echo "This script requires root privileges.  sudo'ing..."
    sudo $0 "$@"
    exit $?
fi

echo "root stuff: $@"

Disable guest

echo “allow-guest=false” |sudo tee -a /usr/share/lightdm/lightdm.conf.d/50-ubuntu.con

eclipse

Ubuntu 12.04: sudo apt-get install -y eclipse

Ubuntu 14.04: not all plugins I want are compatible with newer eclipse. Rolled back to known good version

pydev

Eclipse install URL:

Plugin Eclipse Works? Notes
4.4.0 3.7.2 Yes
4.4.0 3.8.2 No

Installed into 3.7.2 (the normal menu method might have worked just fine) by

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
    Run: ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/
PyDev
    http://pydev.org/manual_101_install.html
    Launch eclipse
    Help => Install new software
    http://pydev.org/updates
    check the regular (non-mylyn) build
    uncheck contact for updates
    hit install

veditor

http://sourceforge.net/projects/veditor/

Installed eclipse:

  • sudo net.sourceforge.veditor_*.jar cp /usr/share/eclipse/plugins/

Stand alone eclipse:

  • Standalone: cp net.sourceforge.veditor_*.jar /opt/eclipse-SDK-3.7.2/dropins/
  • Installed: sudo net.sourceforge.veditor_*.jar cp eclipse/plugins/
    • Should probably be dropins
Plugin Eclipse Works? Notes
1.2.0 3.7.2 Yes
1.2.1.b 3.7.2 Yes
1.2.1.b 3.8.1 No
1.2.1.b 3.8.2 Yes

Default eclipse with Ubuntu:

  • 12.04: 3.7.2. Use 1.2.0
  • 14.04: 3.8.1. Install eclipse 3.8.2 to use 1.2.1.b

wireshark

non-root:

  • sudo dpkg-reconfigure wireshark-common
  • say yes to allow non-root
  • sudo usermod -a -G wireshark $USER
  • log out and log back in

Java

sudo apt-add-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

Thunderbird

Criticism

  • Search: default search is terrible
    • Why: poor sorting ability (ex: can't look at oldest messages easily), low density
    • Workaround: use quick search. It allows to use all filtering on the standard view. Unfortunately, it can't search across folders
  • Send-receive correlation: there is none
    • Workaround: “Thunderbird conversations” seems to fix this

Performance troubleshooting:

  • Ubuntu 14.04: found that “Messaging Menu and Unity Launcher Integration 1.3.1” caused a very noticeable performance degradation. I'm not using Unity and maybe its getting stuck not finding unity. Disabled
  • I had encrypted mis-configured (something like TLS instead of SSL on an SSL port). It worked (re-negotiated?) but was really slow. Fixing configuration solved the issue. Is this a Thunderbird bug and should have outright failed?

Plugins:

  • Disable all default plugins
  • Install “Search Results Sort By Date not Relevance”
  • Used to use lightning but complicated corporate policies prohibit its use now
  • Thunderbird conversations: I had this enabled before but disabled it. Don't recall why

ubuntu-tweak

sudo add-apt-repository http://ppa.launchpad.net/tualatrix/ppa/ubuntu
sudo apt-get install ubuntu-tweak
ubuntu-tweak

gnome-terminal

Increase tab contrast: http://askubuntu.com/questions/40332/how-to-make-selected-tab-in-terminal-more-prominent

White (default is light gray on very slightly different light gray):

cat>~/.config/gtk-3.0/gtk.css <<EOF
TerminalWindow .notebook tab:active {
    background-color: #fffffF;
}
EOF

You must close and reopen gnome-terminal to take effect

bashrc

mkdir -p ~/lib/python
mkdir ~/bin
cat>>~/.bashrc <<EOF
export PATH=~/bin:$PATH
export PYTHONPATH=$PYTHONPATH:~/lib/python
EOF

W520 graphics

Seems my W520 is a lot slower than my older t61p. I suspect it may just be on battery (solution: turn off power management) but want to run some benchmarks. Also possibly seen some contention issues w/ VMWare

Results:

Troubleshoot

Good

Reasonably well working W520 configuration. I used to have the freeze problem but after some fiddling it went away. RAM upgrade?

  • Driver: NVIDIA 352.63
  • OS: Ubuntu 14.04 x64
  • CPU: Intel(R) Core(TM) i7-2760QM CPU @ 2.40GHz
  • RAM: 32 GB (4 x 8 GB)
  • BIOS video settings
    • Boot display device: ThinkPad LCD
    • Graphics Device: NVIDIA Optimus
    • OS Detection for NVIDIA Optimus: Enabled
$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [Quadro 1000M] (rev a1)

$ glxinfo |grep -i vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Bad

Bad configuration (random freezes):

  • Driver: 352.63
  • OS: Ubuntu 14.04 x64
  • CPU: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
  • RAM: 8 GB
  • BIOS display settings
    • Boot display device: ThinkPad LCD
    • Graphics Device: NVIDIA Optimus
    • OS Detection for NVIDIA Optimus: Enabled
$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [Quadro 1000M] (rev a1)

$ glxinfo |grep -i vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation


Uninstalled network manager

I've had this occur a few times when I try to purge something. I don't know why network manager aggressively tries to uninstall itself. Fix is something like this (once you know your network parameters, ie from a computer DHCP'd on the same subnet)

ifconfig eth3 192.168.155.123
route add default gw 192.168.155.1
echo 'nameserver 10.1.2.3 ' >/etc/resolv.conf 
apt-get install -y ubuntu-minimal network-manager
sudo start network-manager
 
ubuntu.txt · Last modified: 2017/11/09 16:29 by mcmaster
 
Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution 4.0 International
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki